現在、参考ページの情報をもとに最新の方法を調査中です。

トラブルシューティング

XCode 5.1 で、gemやbundlerでRubyGtk2をビルドする時にエラーになる

XCode 5.1では以下の様なエラーが発生することがあります

   1 clang: error: unknown argument: '-multiply_definedsuppress' [-Wunused-command-line-argument-hard-error-in-future]

以下の環境変数を指定して gem や bundle を実行します

   1 # in bundler
   2 ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future bundle
   3 # in gem
   4 ARCHFLAGS=-Wno-error=unused-command-line-argument-hard-error-in-future gem install gtk2

参考ページ

MikutterInstallBattle/MacOSX (last edited 2014-04-23 10:00:20 by toshi_a.oid)